Jump to content
  • Announcements

    • Laura L.

      License Activation Portal   12/21/2017

      UPDATE: We are happy to announce that we have published a License Activation Portal on our GoNitro Support page: www.gonitro.com/support Please use this tool for activation issues, such as Error -23, before logging a Support Ticket or posting on the Community Forum.  Please be aware that this License Portal is to be used only by our Online/single users, not by our Business/Enterprise customers.
  • 0
Dennis D

Cannot submit support request.

Question

Dennis D

Over two months ago I installed a windows 7 update.  My Nitro version 10 stopped working.  I tried to reinstall it, and it said my serial number had already been used.  I tried to submit support ticket, and nothing happens.  I tried to upgrade to 11, and it would not respond when I entered my serial number.  Here is the most recent attempt at a support ticket

 

Edited by Kelvin V.
removed the screenshot that had personal information

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
Kelvin V.

Hi @Dennis D,

Thanks for posting on our community forums!

We're really sorry about the issue with the ticket submission. It is now working and we created a ticket in your behalf. Kindly check your email for our response and please let us know if you need further assistance. 

Thank you for bearing with us.

 

Share this post


Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.