Jump to content
  • 0
Dennis D

Cannot submit support request.


Dennis D

Over two months ago I installed a windows 7 update.  My Nitro version 10 stopped working.  I tried to reinstall it, and it said my serial number had already been used.  I tried to submit support ticket, and nothing happens.  I tried to upgrade to 11, and it would not respond when I entered my serial number.  Here is the most recent attempt at a support ticket


Edited by Kelvin V.
removed the screenshot that had personal information

Share this post

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
Kelvin V.

Hi @Dennis D,

Thanks for posting on our community forums!

We're really sorry about the issue with the ticket submission. It is now working and we created a ticket in your behalf. Kindly check your email for our response and please let us know if you need further assistance. 

Thank you for bearing with us.


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


Important Information

By using this site, you agree to our Terms of Use.