Jump to content
Dennis D

Cannot submit support request.

Recommended Posts

Dennis D

Over two months ago I installed a windows 7 update.  My Nitro version 10 stopped working.  I tried to reinstall it, and it said my serial number had already been used.  I tried to submit support ticket, and nothing happens.  I tried to upgrade to 11, and it would not respond when I entered my serial number.  Here is the most recent attempt at a support ticket


Edited by Kelvin V.
removed the screenshot that had personal information

Share this post

Link to post
Share on other sites
Kelvin V.

Hi @Dennis D,

Thanks for posting on our community forums!

We're really sorry about the issue with the ticket submission. It is now working and we created a ticket in your behalf. Kindly check your email for our response and please let us know if you need further assistance. 

Thank you for bearing with us.


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.