Jump to content

Default Zoom Settings


OMGTR
 Share

Recommended Posts

  • Power User
Steven Zakulec

Your documents are using the view settings they last had when you closed them.  To turn this off, go to File, Preferences, Appearance, and uncheck "Restore last view settings when reopening a PDF".

If that doesn't fix the issue, or I didn't understand the issue correctly, let me know.

Link to comment
Share on other sites

Thank you for the fast response, but unfortunately this did not solve my problem.
My target is, if I open a random document, the zoom setting should be automatically set to 100 %.

Btw: I'm using Nitro 10.5.9.9 with W10.
 

Link to comment
Share on other sites

  • Power User
Steven Zakulec

I imagine you've checked this, but just in case not: There's a setting for Default Zoom under File, Preferences, Page View.  Hopefully setting that to 100% should fix the issue.

Link to comment
Share on other sites

  • 1 month later...

I found the setting for default view and set for 100%.  The setting does nothing at all.  Somewhere there is a very strong preference for 'fit page width' and this is ridiculously large for a wide screen hi res monitor.  Remembering previous zoom setting does not address the issue.  I am plowing thru .pdf files found by web search, so I have no prior zoom setting for them.  I need the initial view to stay 'single page continuous', '100% zoom'.  Default zoom setting does NOT work.

Nitro seems to replicate the zoom settings of Acrobat reader, complex and no actual control.  I installed Nitro hoping for something simpler.  

Link to comment
Share on other sites

  • Power User
Steven Zakulec

You can try to set this through registry keys if you're comfortable doing that.

I successfully had a PDF I had never opened before use the 100% zoom & Continuous settings with Nitro 11.0.7.425.

You should always be very careful editing the registry- none of the Nitro keys are likely to cause issues to your computer or Nitro, but there's always a chance something could break, and exporting a copy of the key is never a bad idea before you start.

That being said, here's the keys you want to change, and what to change them to:

Go to Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences\kPreferences

If you want to change the default for Page View, change the value of kPrefGeneralDefaultView to one of the options below ( /i 0 to /i 4).

Default Page View (kPrefGeneralDefaultPageView)
Automatic (/i 0)
Single Page (/i 1)
Continuous (/i 2)
Facing Pages (/i 3)
Continuous Facing (/i 4)

To change the default zoom set kPrefGeneralDefaultZoom to one of the values below (/t something):
Automatic (/t Automatic)
Actual Size (/t Actual Size)
Fit Page (/t Fit Page)
Fit Width (/t Fit Width)
25% (/t 25%)
50% (/t 50%)
75% (/t 75%)
100% (/t 100%)

Good luck, and tell me if this works or not.

Link to comment
Share on other sites

Hi

Thank you very much for the answer but it didn't solve the problem 100 %.
When I open documents, converted from SAP via PDFForge PDFCreator then it will be displayed in full size.
In Nitro it's always 152% but for example the default view % setting in Acrobat Reader does not change.

So I think its still a Nitro problem, what do you think?

Thanks in Advance.

Link to comment
Share on other sites

Default setting works 'sometimes'. 

Here's an example of a pdf that sets 'fit page width' when downloaded to my computer. 

http://www.analog.com/media/en/technical-documentation/data-sheets/AD8541_8542_8544.pdf

I tried changing the page view default zoom to 50%, and then most pdf files default to 50% as expected (but not this one).  I set the default page view back to 100% and then most pdf files default to 100% as expected (but not this one).

This is just a guess, but there may be a setting in pdf author software that controls the settings of the pdf reader. 

Link to comment
Share on other sites

  • Power User
Steven Zakulec

Okay- this appears to be something entirely different. There's a way you can specify Document View settings in a PDF that tell the viewer the recommended way to display it.

As far as I know, there's not a way to override this.  It's possible there's some Javascript you could use that would do this for you, but that's beyond me.

If you want an option that will disregard the Document View setting, leave that in the Product Improvement forum.

Link to comment
Share on other sites

Steven, thanks for that info.  This explains why the Adobe reader never gets fixed.  The Adobe forums have accumulated years of whining about this.  Adobe intended it this way.  Adobe puts all control in the (paid) authoring software.  The (free) reader has functionality stripped.  

The zoom setting is for me to decide, based on my screen size and my intended use.  The pdf author only sees their own screen and has no basis for choosing the reader's view.  The author might not even know that their Document View is getting embedded in what they produce.  It is Adobe's mistake to include such a feature.  I look to a non-Adobe reader for a cleaner implementation that ignores the embedded Document View.

Edited by curmudge
Link to comment
Share on other sites

  • 1 year later...
On 3/14/2018 at 3:47 PM, Steven Zakulec said:

You can try to set this through registry keys if you're comfortable doing that.

I successfully had a PDF I had never opened before use the 100% zoom & Continuous settings with Nitro 11.0.7.425.

You should always be very careful editing the registry- none of the Nitro keys are likely to cause issues to your computer or Nitro, but there's always a chance something could break, and exporting a copy of the key is never a bad idea before you start.

That being said, here's the keys you want to change, and what to change them to:

Go to Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences\kPreferences

If you want to change the default for Page View, change the value of kPrefGeneralDefaultView to one of the options below ( /i 0 to /i 4).

Default Page View (kPrefGeneralDefaultPageView)
Automatic (/i 0)
Single Page (/i 1)
Continuous (/i 2)
Facing Pages (/i 3)
Continuous Facing (/i 4)

To change the default zoom set kPrefGeneralDefaultZoom to one of the values below (/t something):
Automatic (/t Automatic)
Actual Size (/t Actual Size)
Fit Page (/t Fit Page)
Fit Width (/t Fit Width)
25% (/t 25%)
50% (/t 50%)
75% (/t 75%)
100% (/t 100%)

Good luck, and tell me if this works or not.

 

Link to comment
Share on other sites

Do you have a registry setting to change the Document Properties > Initial View for Facing Pages and Left as an option.

 

 I have tried setting it for each document sometimes it works and sometimes it doesn't - when it doesn't the first page is a single one showing on the righ when choosing Facing Page view

Link to comment
Share on other sites

  • Power User
Steven Zakulec

I think I do.

You'll set kPrefGeneralDefaultPageView to /i 3

Then you'll make a new string value called kPrefPageViewFacingPagesDefault

For left, set this to /i 0 ; for right, set to /i 1

I've tried this in Nitro 12 only.

 

Link to comment
Share on other sites

Thanks for the setting  but they still open with the first page on the right, subsequent pages are facing side by side - I have checked on Document Propeties that the Initial View is set to Left, so I have no idea why it doesn't work. The way I have got round this is to insert a tile page as the first page so that subsequent pages display correctly, but I opened one of the pdf's saved that way and it started to display them as facing pages, so I removed the title page and every time I open it now it displays as facing pages correctly. So I dobn't know what is gpoing on. I have checked several files to ensure the Document Properties is set up correctly and I though that the only thing could be the registry settings overriding the initial view, but now that doesn't appear to be the case. Any ideas?

 

 

 

Link to comment
Share on other sites

  • 4 weeks later...

I don't have Nitro VIP, but as an update, I can now get the 2 page with left facing to work in the document using File > Preferences > Page View > Default Facing Pages > Left and they appear side by side but when I open them full screen the left hand side is blank and just one page appears on the right, subsequent pages are shown side by side but the pages I want to stay together are out of sync. Any ideas?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.