Jump to content
Michael Butts

Page Scaling Default

Recommended Posts

Michael Butts

Hi

I'm using NitroPro 11 on a Win7 Pro machine.

Is there a way to set the default page scaling under Print to Shrink to Fit Printable Area?

Share this post


Link to post
Share on other sites
Steven Zakulec

There should be, but you need to set a registry key.

You want to create and/or edit the kPagePrinterScaleSelector key in Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences\kPreferences.

If the key does not exist, you want to create a String type key with that exact name (case and all).

There are 3 values that you can use: /i 0, /i 1, and /i 2.

Each corresponds to the Scale settings in the Print Dialogue:

0 is no scaling

1 is Expand to fit

2 is Shrink to fit

You'll want to have Nitro closed when you do this, and when you re-open it your change should take effect.

Share this post


Link to post
Share on other sites
Michael Butts

Steven,

Thanks for the info.  With Nitro closed, I added the key as a string with the value of /i 2.  I opened a PDF in Nitro and the Page Scaling still shows "none" on the print page.  Should that show the "shrink to fit" checkbox checked?

Share this post


Link to post
Share on other sites
Steven Zakulec

That box really should be checked- with my copy of Nitro 11.0.7.425, setting that key makes every document use that as the default print setting.

There's other keys you could try:

In that same list from above, you'll see kPrefPrintScalingShrink listed.  For this key, you should use /b 1 for on, and /b 0 for off.

The third option you can try is creating a key called PrintSettings in Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences.

Inside, you'll create a string called kPagePrinterScaleSelector.  You'll use the same /i 0, /i 1, /i 2 as above for the value.

For earlier versions of Nitro 11, you could try this below as well:

HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences\PrintSettings > kPagePrinterScaleSelector 

>> Set the regkey to '1' 

>> NOTE: You are required to use the Ctrl + P shortcut rather than File > Print to utilise this.

 

None of this is officially documented, so I'm not entirely sure what's supposed to work with what version- if one of these does work, please let me know.

Share this post


Link to post
Share on other sites
Michael Butts

A-ha!  The auto-update wasn't working and I was still on 11.0.6.326.  I downloaded 11.0.7.425 and your suggested registry edit is now working.

Thanks a ton!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.