Jump to content
WH57

Nitro Pro 12 - all PDFs are pixelated/blurred

Recommended Posts

WH57

I updated from Nitro Pro 10.5.5.9, on a desktop running Windows 10 Pro v1803 build 17134.48, to Nitro Pro 12. PDFs that had previously looked sharp suddenly became pixelated (both text and graphics). If I opened them in Adobe Acrobat Reader DC they still looked sharp. The Nitro Pro 12 window itself looked somewhat blurred, unlike the crisp Nitro Pro 10 window. I was unable to find a setting that fixed the issue. I uninstalled Nitro Pro 12 and reinstalled Nitro Pro 10; the PDFs are back to their original clarity and crispness, in Nitro Pro 10.

My monitor is a Dell P2715Q connected to an NVIDIA GeForce GTX 760 card. The resolution is 3840 x 2160 and refresh rate is 59 Hz. The display "scale and layout" is set at 200%. Nothing has changed in this setup over the last 4 years. Nitro Pro 9 & 10, Acrobat Reader DC, MS Office and many other applications have worked very well. Only Nitro Pro 12 has a problem.

Can someone please guide me on what I need to do to fix this problem? As it stands right now, Nitro Pro 12 is unusable for me. And I have bought 5 licenses :(

Thank you.

 

Share this post


Link to post
Share on other sites
kwn

I have the same problem. Text is very blurred on Nitro 12 - sharp on Nitro 10 and other pdf viewers. I have an Nvidia GeForce GTX 750 Ti card on Windows 10 64 bit with recent 1803 update. I submitted a support ticket but was told I'm not supported, despite paying for 12months software assistance in Feb 2018!

Share this post


Link to post
Share on other sites
kwn

I've also now tried Nitro 12 on my portable device - same Windows version as my main PC but integrated Intel HD Graphics card - no improvement with Nitro 12 - text still blurry. Nitro 10 working fine on that device also.

Any assistance to resolve this issue would be much appreciated.

Share this post


Link to post
Share on other sites
WH57
On 6/1/2018 at 11:09 PM, WH57 said:

I updated from Nitro Pro 10.5.5.9, on a desktop running Windows 10 Pro v1803 build 17134.48, to Nitro Pro 12. PDFs that had previously looked sharp suddenly became pixelated (both text and graphics). If I opened them in Adobe Acrobat Reader DC they still looked sharp. The Nitro Pro 12 window itself looked somewhat blurred, unlike the crisp Nitro Pro 10 window. I was unable to find a setting that fixed the issue. I uninstalled Nitro Pro 12 and reinstalled Nitro Pro 10; the PDFs are back to their original clarity and crispness, in Nitro Pro 10.

My monitor is a Dell P2715Q connected to an NVIDIA GeForce GTX 760 card. The resolution is 3840 x 2160 and refresh rate is 59 Hz. The display "scale and layout" is set at 200%. Nothing has changed in this setup over the last 4 years. Nitro Pro 9 & 10, Acrobat Reader DC, MS Office and many other applications have worked very well. Only Nitro Pro 12 has a problem.

Can someone please guide me on what I need to do to fix this problem? As it stands right now, Nitro Pro 12 is unusable for me. And I have bought 5 licenses :(

Thank you.

 

Does anyone have any ideas or advice?

Share this post


Link to post
Share on other sites
kwn

Having given up on this and reverted back to Nitro 10 for trouble free use, I then received a response from Leslie V. with a suggestion which worked for me. This is on Windows 10 64 bit with all updates - Right click on Nitro program file (or shortcut icon), Open Properties -> Compatability-> Change High DPI setting-> check box against High DPI Scaling Override. Worked for me!

  • Thanks 3

Share this post


Link to post
Share on other sites
WH57

kwn, thank you very much for passing on this suggestion. I haven't tried it out yet, but will post after I do. I find it fascinating that nobody from Nitro came forward this suggestion/solution...

Share this post


Link to post
Share on other sites
BC_
On 6/19/2018 at 5:07 PM, kwn said:

Having given up on this and reverted back to Nitro 10 for trouble free use, I then received a response from Leslie V. with a suggestion which worked for me. This is on Windows 10 64 bit with all updates - Right click on Nitro program file (or shortcut icon), Open Properties -> Compatability-> Change High DPI setting-> check box against High DPI Scaling Override. Worked for me!

I do have the same problem, unfortunately the "Change High DPI setting" is not active, I can not check the box, why may that be? Is there a workaround? Pls help.

Share this post


Link to post
Share on other sites
AllainU

Hello @BC_,

Thank you for reaching out to us through our Community Forums!

I believe you're using Windows 7 and options are grayed-out. With this, please refer to this MS article. Please note that this will impact ALL applications, not just Nitro Pro:
https://technet.microsoft.com/en-us/library/ff629368.aspx

This article should explain why those options are grayed-out in Windows 7:
https://superuser.com/questions/282648/windows-7-cannot-turn-off-dpi-ppi-scaling-for-an-application

Thanks for choosing Nitro Pro and I hope this helps!

Share this post


Link to post
Share on other sites
JamiePUK

@AllainU, @kwn 's 19 June 2018 solution is the answer to the same problem on new Windows 10 64bit installation.

Perhaps Nitro could make the solution easier to find.

 

Happy New Year

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.