Jump to content

Kensington Docking station


Recommended Posts

I have just replaced my HP docking station with a Kensington one and since then every time I open a PDF with Nitro Pro it takes more than a minute to open. I have the latest driver from Kensington so does anyone else have this problem and is there a fix?

Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @Garry,

Thanks for posting on our community forums!

This is the first time we have received such concern where Nitro Pro is running slow when opening a PDF after replacing a docking station.

In order for me to further assist you, please provide me with the following:
-What OS is installed in your computer (Windows 7, 8.0, 8.1 or 10 and whether it is 32-bit or 64 bit)?
-What build of Nitro Pro are you working with? You can find this out by clicking on 'About Nitro Pro' under the Help tab (format is 11.X.X.X, e.g.
-Are any other users able to replicate the issue, or is it just the one computer / user?
-Does this happen with every file? If it's a single file, please PM me a sample file so I can replicate it on my end
-Where are the files saved (local, a shared drive or an external drive) when you’re trying to convert? Can you check if you have the same issue when the file is saved locally?
-Have you tried running a repair of your Nitro Pro?

Thank you very much in advance and I am looking forward to hearing back from you. 

Link to comment
Share on other sites

Hi Allain,

  • It is a Surface Pro 3 running Windows 10 64 bit
  • The version of Nitro Pro is
  • None of the other users are experiencing the same problem but the set up is unique to me Nitro Pro, Surface Pro 3, new Kensington docking station etc...
  • Every file and even if you try to open the application without a file
  • Files are local and within e-mail and on the network, same response to all except when Nitro is already running with an open file
  • No I have not, is there an option for that?

Like I say, works perfectly well with a HP docking station and when I remove the docking station and just work from the tablet it is also fine.

Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @Garry,

Thanks for your patience and for providing these information.

Since this is a rare behavior and you're still using an older build of Nitro Pro 11, kindly refer to below steps to update to

1. Clear the content of the directory under C:\users\your_username\Appdata\local\temp. For whatever reason, not all temp files automatically remove themselves and is NOT usually caused by Nitro Pro files.

2. Download and run our Clean Up utility to uninstall your Nitro Pro: http://install.nitropdf.com/support/downloads/cleanup.zip

NOTE: This clean-up tool will erase any existing signature files within Nitro so please save them to another location before using the clean-up tool in order to keep them. Please see this link for backing up custom stamps/signatures: http://kb.gonitro.com/knowledgebase#/search/stamps/000001686

3. Extract the utility to the desktop (it doesn't always run from the zip)
4. Run the utility then reboot your machine.
5. Now manually check for left over registries from Nitro Pro (Run > regedit) and delete them. Make sure to save a backup before making any change. Reboot the machine again after deleting Nitro Pro traces.
6. Please clear all your downloads folder or delete all downloaded Nitro installers. This step is important because we noticed that if you are saving all the installers and you download them in the same folder (like the downloads folder), the EXE can pick up any MSI installed in that folder and you may pick-up one of the older builds instead of the newly downloaded package.

7. Download and install Nitro Pro using offline installers:

x64 http://install.nitropdf.com/professional_1108470/en/burn/nitro_pro11_ba_x64.msi
x32 http://install.nitropdf.com/professional_1108470/en/burn/nitro_pro11_ba_x86.msi

If you are not sure which to pick, this will help: http://kb.gonitro.com/knowledgebase#/search/64/000001874

8. After installation, you can activate by opening Nitro Pro, clicking on the Help tab > About Nitro Pro > Activation and entering your serial number.

Thanks for choosing Nitro Pro and I hope this helps!

Link to comment
Share on other sites

Hi Allain,

That appears to have worked although it did not ask me to re-enter my serial number, the only option was to 'deactivate'. PDF's are opening normally now.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.