Jump to content

Nitro Pro 9 stopped launching


Recommended Posts

I purchased my Lenono desktop computer with Nitro Pro 9 basic pre-installed for free about 4 years ago.  This version allowed me to open and edit PDF files and I primarily used it to sign documents.  It worked for many years then all of the sudden it stopped launching.  I don't get any error message, but despite how many times I click on the app it doesn't launch.  I can't un/reinstall it because I'm worried I'll lose my free license.  How can I fix this launch issue?

Link to comment
Share on other sites

  • Power User
Steven Zakulec

Have you tried repairing it (http://kb.gonitro.com/knowledgebase#/search/repair/000001641 ) yet?

Does it work again at least one time after you reboot your computer?

You might be able to use the last released installer from this page ( http://kb.gonitro.com/knowledgebase#/search/previous version/000001644) to update and fix Nitro 9 if the repair above didn't work.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.