Jump to content

Fill Forms for Date Error


Recommended Posts


I'm working with various protected forms that do not allow for me to edit the parameters of the form fields,  such as the one that can be found here: https://www.uscis.gov/system/files_force/files/form/i-765.pdf?download=1

When I input dates using the CORRECT format (e.g. 05/02/1998) in the forms, such as the one found on page 3, question 20 of the above form,  Nitro Pro errors out and states "Please enter 2 digit month, 2 digit day and 4 digit year." I have also tried selecting a date from the calendar and tried entering a date without the "/". Nothing seems to stop this error. I do not believe that I can edit the form. Any thoughts on what is going on and/or fixes?

The forms work on the Adobe X versions that I have. I was considering purchasing more licenses of Nitro Pro, but we need this issue to be resolved.

Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @CM1,

Thank you for reaching out to us through our Community Forums and I do apologize for the issue you're experiencing.

Please note this document was created using a program called Adobe Designer (see the Document Properties of the file), which utilizes XFA / XML forms architecture that is not compliant with the PDF 2.0 specification set by the ISO (International Organization for Standardization). Our Product & Engineering team is actively investigating options to improve Nitro's ability to handle XFA and other non-standard PDF document-types, but this is a significant product roadmap initiative, and unfortunately, there isn't a short-term solution. 

Although we have improved on how we work with this format, some files will still not behave as expected. 

If you intend to simply view or fill in the form fields in this specific file, as this is a proprietary Adobe format, we suggest using Adobe reader.

Please note that the results may vary with this workaround.

Again, my apologies for this inconvenience on behalf of Nitro.

Link to comment
Share on other sites

  • 3 years later...
Ashish Tuli

I am having the same problem, so it's not been fixed as yet over two year later? It's not possible to use Adobe Reader as they dont allow form filling using the free version. Will need to get a paid version, which is kind of what I got Nitro Pro for.

Edit: More importantly, once this error shows up, there is no way to stop it from popping up and work on other fields unless you close the file and re-open it. This is a pretty big usability issue to go unresolved for two years.

Edited by Ashish Tuli
Additional information about the error.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.