Jump to content
Kaiso

Cannot install Nitro Pro 11 on a new machine.

Recommended Posts

Kaiso

I bought a new machine and would like to install my Nitro 11 on it. However, I the installation kept crashing with the error "Nitro Pro Setup wizard ended prematurely because of an error. Your system has not been modified. To install this program at a later time, run setup wizard again". 

I assumed the problem might be number of activations. I deactivated and tried again several times. No go. 

 

Nitro_Error.png

Share this post


Link to post
Share on other sites
AllainU

Hello @Kaiso,

Thank you for reaching out to us through our Community Forums!

In most cases, uninstalling your MS Office and rebooting your machine will allow you to install your Nitro Pro 11. Could you please try that on your end?

If you have done that already but you are still unable to install the program, kindly note we have identified that the cause of this issue is permission/ownership access to WindowsApps folder. Even if your Windows account is a member of Administrator group or you are logged in using administrator account, the installation will fail as the account does not have permission/ownership to access WindowsApps folder. To confirm this, here are the steps:

1. Enable the 'Hidden items' in Windows Explorer as the WindowsApps is hidden by default.
2. Go to C:\ProgramFiles\ then double click WindowsApps folder. A window will pop-up telling you that 'You don't currently have permission to access this folder'

As a workaround, kindly follow these steps:

1. Carefully follow the steps up to step 7 on this KB article: http://kb.gonitro.com/knowledgebase#/search/failed/000003265 

Please take note of the following: 
• You are required to run CMD in administrator mode. 
• If Windows says '-' is not recognized as an internal or external command, operable program or batch file, remove the '-' when executing the commands.

The above article will allow your user account to take ownership and gain permission to access the WindowsApps folder. 

2. Go back to C:\ProgramFiles\ then double click WindowsApps folder.
3. Click 'Continue' to permanently get access to this folder.
4. At this point, since your user account already have permission and ownership to the folder, clicking Continue will give you access to WindowsApps folder. 
5. Close WindowsApps folder then open it again, you should no longer get the message 'You don’t currently have permission to access this folder' pop-up message.

After the above steps, please clear all your downloads folder or delete all downloaded Nitro installers. This step is important because we noticed that if you are saving all the installers and you download them in the same folder (like the downloads folder), the EXE can pick up any MSI installer in that folder and you may pick-up one of the older builds instead of the newly downloaded package.proceed on installing 

Then install Nitro Pro 11 using below offline installers:
x64-bit: http://install.nitropdf.com/professional_1108470/en/burn/nitro_pro11_ba_x64.msi 
x32-bit: http://install.nitropdf.com/professional_1108470/en/burn/nitro_pro11_ba_x86.msi

If you are not sure which to pick, this will help: http://kb.gonitro.com/knowledgebase#/search/64/000001874 

After installation, you can activate by opening Nitro Pro, clicking on the Help tab > About Nitro Pro > Activate and entering your serial number.

Thanks for choosing Nitro and I hope this helps!

Share this post


Link to post
Share on other sites
Kaiso

Seriously? I'm installing software on a new machine that includes AutoCAD, Rhino3d, and other major packages. None had problems installing or require steps like you detail. You must seen how this reflects poorly on Nitro?  At any rate, your instructions came too late and I purchased a competing PDF package for this new machine. I will leave Nitro installed on my old machine. But I can't see going forward with the program if this procedure is required. Though I don't use/have MS Office, I can't imagine telling an IT department to remove MS Office if they want to install Nitro. Very poor.

Share this post


Link to post
Share on other sites
AllainU

Hello @Kaiso,

My sincere apologies for the steps we have provided you.

I fully understand that it is quite hard to perform and with a few users, my initial statement does not apply if they do not have MS Office installed.

To share some information, our product team investigated this issue last year and they found out this is a permission issue with WindowsApps folder inside C:Program Files that affected Nitro Pro 11 and other apps as well.

In their initial investigation, if MS Office that was purchased from their online Marketplace, the said folder by default is restricted preventing Nitro from accessing the folder to install the Add-ins.

To get enough permission to install Nitro Pro Add-ins, above steps was finalized to helped a lot of our Nitro Pro 9, 10 and 11 users when installing our program on their Windows 10 machines.

Though a few users did not purchase / install MS Office from online Marketplace, some of them contacted us with the same error message we were able to help them using the same steps. 

For your reference, you may visit this forum post https://community.gonitro.com/topic/5280-kkho/?tab=comments#comment-13879

Should you have further questions, please do not hesitate to reach-out again.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.