Jump to content

Nitro Pro 12 PDF creator wont print

Chris Peterson

Recommended Posts

Chris Peterson

I recently accidentally upgraded to nitro Pro 13 not realizing I had 12 before, removed 13 and reinstalled 12 and activated using my serial number from the original purchase. Now when I print to PDF using the nitro pdf creator, it "prints" but just sits in the queue forever and does not do anything. I've tried uninstalling and removing everything Nitro related, but am I missing something or is there a driver I need to re-install? This is very frustrating and is hurting my productivity at work. 

Current version:

This is the case for any and all files I am trying to print to Nitro PDF creator from all programs

No error message, just the documents sitting in the queue saying "sent to printer"



Link to comment
Share on other sites

Chris Peterson

Completely removed every single file on my computer that was related to Nitro... shut down my computer, re-booted, re-installed Nitro with Serial Number, tried to print document from Microsoft Word, everything in the print dialogue was fine, dialogue for the file name came up and filled that in, hit print, and now the file is just sitting in the printer queue with the status "sent to printer" nothing happening. I'm not sure what the issue is, i've also submitted 2 support tickets and gotten no response from those.



Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @Chris Peterson,

Thank you for reaching out to us through our Community Forums and sincere apologies for this inconvenience.

Could you please share how did you submit support cases to reach out for help? We would like to know this information because upon checking your account, we are unable to find these tickets.

To further troubleshoot this issue, kindly uninstall and reinstall your Nitro PDF Creator by referring to these steps:

A. To uninstall PDF creator:
1. Open Control Panel.
2. Click on System and Security.
3. Click on Administrative Tools.
4. Double-click the Print Management.
5. Expand the Custom Filters.
6. Click on All Drivers.
7. Right-click Nitro PDF Creator and select the Delete option

B. To clear the Spool queue:
1. Select Start > Type Command > Right-click “Command Prompt” and select “Run as administrator“.
2. Type net stop spooler then press “Enter“.
3. Type del %systemroot%\System32\spool\printers\* /Q then press “Enter“.
4. Type net start spooler then press “Enter“.

The print queue on your Windows should now be cleared. Type exit, then press “Enter” to exit the command window.

C. To install our Stand-alone PDF Creator using below direct installers:
x32: http://install.nitropdf.com/professional_12163574/en/enterprise/Nitro_Creator_x86.msi 
x64: http://install.nitropdf.com/professional_12163574/en/enterprise/Nitro_Creator_x64.msi

If you are not sure which to pick, this will help:  https://kb.gonitro.com/knowledgebase#/search/64/000003790 

If above steps did not help and in order for me to further assist you with this issue where printing jobs are stuck in the printer queue, could you please provide me with the following as well?:

-Is this a new issue or has it occurred since after installing Nitro Pro? Any changes you are aware of before this happened (e.g. Windows Updates)?
-How many users reported this issue when using this software so far?
-Is Nitro Pro 12.16 installed on a physical machine or virtual?
-Are the PDF files you are printing to PDF Creator saved in a network drive? If saved locally, is the same issue present?

Thank you very much in advance and I am looking forward to hearing back from you.

Link to comment
Share on other sites

Chris Peterson

I will run through the solutions given and get back to you if they work.

I realized I do not have VIP access, which is why the support tickets did not go through, that was my error. 

This issue started last week randomly, it may have been the result of a windows update, i'm not sure, but If I remember correctly, it stopped working and that's when I most likely made things worse by the uninstalling and reinstalling of the wrong software.

It is just my license on my computer, several other people in my office have nitro pro 12 and have no issues with theirs.

This is installed on a physical machine. 

I tried to save the pdf files to both network drive and locally. 


Will get back to you shortly about the other issues. 

Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.