Jump to content

Trouble activating v12

Chris Worth

Recommended Posts

Chris Worth


So I rebuilt my desktop  machine and deactivated my Nitro Pro 12 installations at the website. It tells me I am active, on v12, with zero activations, and can make 2 valid installations. Then, I downloaded Nitro Pro 12 from the website to my rebuilt machine. However, this went straight into trial mode and did not offer me any step to enter my serial number. Nor does there seem to be an activation option in Help -> About Nitro Pro. Subsequently, I've been receiving the daily Nitro Pro trial countdown emails (and am about to reach the end of the 10 days).

I just tried a de-install/re-install, to see if I'd missed a stage where I could enter the serial number. The application has just gone straight to the same stage as before. I went back to Help -> About Nitro Pro and tried the deactivation step in there i.e. I was hoping that deactivating the trial version would allow me to do the proper activation. However, the deactivation requires entry of the serial number and, when I entered my number, the system gave an error 20 and declared the serial number invalid.

I've been a Nitro Pro user since around version 8 or 9 and have rebuilt many computers and installed/re-installed many times. I don't recall having any issues in the past. Has the process changed or have I lost the plot? Please advise on how to get this properly activated...


Link to comment
Share on other sites

  • Official Nitronaut

Hello Chris,

Thanks for reaching out to us!

Please use the tool I have provided below to remove all files associated with Nitro Pro and reboot your system.

NOTE: This clean-up tool will erase any existing signature files within Nitro, so please save them to another location before using the clean-up tool in order to keep them. Please see this link for backing up custom stamps/signatures: https://kb.gonitro.com/knowledgebase#/search/stamps/000004307

When your system is back up, close all of your open applications and install Nitro Pro from the page I have provided below:

Then try activating again.

I hope this helps! Please let me know how that goes.

Link to comment
Share on other sites

Chris Worth

Hi Leslie  - thanks for your help. I've been travelling and have only just got back to this.

I removed the (expired) trial version of Nitro Pro 12 and ran the tool you provided. The script seemed to execute OK (it did require a download of a .NET framework, but that's not unusual). However, when I reinstalled Nitro Pro I still don't see any option for activating via my license key.

At 'About Nitro Pro' all I see is a Deactivate box and no option to activate. My key is 234xxxxxxxxxxxxxxx and the licensing website tells my it's valid for two installations. Any further suggestions?

Edited by Reymund G.
Link to comment
Share on other sites

  • Official Nitronaut

Hello @Chris Worth

If you see a deactivate button, there is no need to reactivate. It is already activated (remembered automatically) and you can use Nitro Pro normally. 

If you are getting other issues using Nitro, please let us know.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.