Jump to content

E-Signing of Documents

Iain MacLeod

Recommended Posts

Good Morning,


Having some issues with getting documents signed, when applying signature i receive a error message "The selected profile is missing its private key and cannot be used to sign this document" 

I have uninstalled the program and reinstalled but same error message is appearing.



Link to comment
Share on other sites

  • Official Nitronaut

Hello @Iain MacLeod

Thanks for reaching out to us!

This error message occurs when the Private Key is missing for that particular Digital Certificate / Digital Signature. Was there a change in your computer's environment? (like an OS update?)

Regardless, this can be solved by creating a new Digital Signature profile. To do so, please  navigate to the 'Protect' tab in Nitro Pro, then select 'My Digital IDs'. On the 'My Digital IDs' dialogue box, please select 'New' and fill out the required information to create a new Digital ID. This Digital ID can then be used to place a Digital Signature.

I hope this helps!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.