Jump to content

Nitro Pro 13 Does not open

Alden Reynoso

Recommended Posts

Alden Reynoso

I had an existing version of Nitro Pro 13 on my PC.   It was working fine yesterday.  Today, it will not open.  It says in Task Manager that it is open, and on the taskbar it says it is open, but the screen will not pull up.  I uninstalled and purchased a new license thinking perhaps the old one had expired.  (I thought it was a one-time purchase?)  Now, I ran the installer and it says it is on the machine, but still when I go to open it, it will not open.  The little window on the taskbar says "expired trial."  I tried to go through the Nitro Pro website to activate the license, but it keeps prompting me to deactivate even though it also shows no licenses are active.    To be clear, I can't even get Nitro Pro desktop version to open so I can input a new serial number.  Please advise. 

Edited by Alden Reynoso
additional informaiton.
Link to comment
Share on other sites

  • Official Nitronaut
Reymund Oyong

Hi @Alden Reynoso

Thank you for reaching out to us through our Community Forums!

I have seen this behavior before when the application launches but just appear in Windows' Taskbar and it does not exhibit any error message. 
Could you please try to do the following and see how it works?:

1. Open Nitro Pro again. 
2. From the Windows Taskbar, focus on Nitro Pro by clicking on it.
3. Press the Windows key + Left/Right arrow on your keyboard until Nitro Pro appears.

Sometimes this happens when Nitro Pro is stuck outside the displayed area on your monitor. 
You can also check if you can move the Nitro Pro window (in case it's off-screen) by holding Shift and right-clicking the Nitro Pro icon in the Taskbar and selecting, "Move". Then, continuously press the Left/Right arrow key on your keyboard until it appears on the screen.

Kind regards,

Link to comment
Share on other sites

Alden Reynoso

Shift and right-clicking worked.  I frequently move between a set up with two monitors and only one.  It makes sense that Nitro may have been off-screen.  Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.