Jump to content

Cannot activate. Cannot use Nitro.

Sarah Dalmasso

Recommended Posts

Sarah Dalmasso

My firm has two licenses.  The one I use stopped working.  I tried de activation and now I cannot activate.  I need to be working.  

Original issue:  I click on a document and it looks like it is being loaded.  The document name goes to the taskbar.  But I cannot see the document.  When I hover over the taskbar - I get either a black page or a white page, small.  I am sure the document is there - I can see it using Adobe.   I tried to deactivate and load updated version.  Still cannot see documents and neither license is activated.


Chirlyn (Sarah is no longer at the firm)

Edited by Sarah Dalmasso
Link to comment
Share on other sites

  • Official Nitronaut
Reymund Oyong

Hi @Sarah Dalmasso,

Thank you for reaching out to us through our Community Forums!

Please check the version of your serial number through our license portal at https://licenses.gonitro.com/prd/portal 

If the version is 12, please ensure that you install Nitro PDF Pro by downloading the installer from the following location:

https://www.gonitro.com/product-details/downloads - click the 'Download Nitro Pro 12' link. 

If the version is 13, you need to install Nitro Pro 13. The installer can also be located from the above link, then click the 'Download Nitro Pro 13' link.

Once you have determined the version of your serial number and the appropriate version is installed on the computer, you should be able to activate the software. 
To activate, go to the Help tab > About Nitro Pro then click the Activate button. 

Regarding the original issue, I have seen that behavior before when the application launches but just appear in Windows' Taskbar and it does not exhibit any error message. 
If you encounter this, please try to do the following:

1. Open Nitro Pro again. 
2. From the Windows Taskbar, focus on Nitro Pro by clicking on it.
3. Press the Windows key + Left/Right arrow on your keyboard until Nitro Pro appears.

Sometimes this happens when Nitro Pro is stuck outside the displayed area on your monitor. 
You can also check if you can move the Nitro Pro window (in case it's off-screen) by holding Shift and right-clicking the Nitro Pro icon in the Taskbar and selecting, "Move". Then, continuously press the Left/Right arrow key on your keyboard until it appears on the screen.

Kind regards, 

Edited by Reymund G.
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.