Jump to content

Latest version: gets wizzard failure and will not install Windows 11.

Ken Bales

Recommended Posts

Tried first to install from link on website.  Then tried removing  Same failure.  Tried running as administrator , same failure.   Tried compatibility mode.  Same failure.  Tried installing version which installed and I activated.   What do I do now.   None of the suggestion I tried on this site produced anything but wizard failure.

Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @Ken Bales,

Thank you for reaching out to us through our Community Forums!

I believe you are installing using our .EXE package so please use our offline English MSI packages below:

x64   https://downloads.gonitro.com/professional_13.67.0.45/en/retail/nitro_pro13_ba_x64.msi
x32   https://downloads.gonitro.com/professional_13.67.0.45/en/retail/nitro_pro13_ba_x86.msi 

To know if you have 32-bit or 64-bit, please refer to this article:

After installation, you can activate it by opening Nitro Pro, clicking on the Help tab > About Nitro Pro > Activate by entering the same serial number 504925-xxyyzz-983589

Thank you for choosing Nitro and I hope this helps.

Link to comment
Share on other sites

This solved the problem.  It took several tries as download keep failing (fyi in case someone else has the problem)  Thanks

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.