Jump to content

unable to request signature


Your Consultancy
 Share

Recommended Posts

Your Consultancy

Hi,

When I upload a document to request signature the browser redirects itself to the home page. I am unable to write the name of signee or their email address. I have tried this on different PCs and different files. It is the same everywhere.

How can this be resolved?

Thank you

Link to comment
Share on other sites

  • Official Nitronaut
Allain Umailin

Hello @Your Consultancy,

Thank you for reaching out to us through our Community Forums!

When you logged into a different machine, did you use the same windows user profile to log in? If yes, have you tried accessing your Nitro Sign account using a different browser?

Thank you very much in advance and I look forward to hearing back from you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.