Jump to content

Word 2010 to PDF error with hyperlinks

Jim MacLachlan

Recommended Posts

Jim MacLachlan

I have Nitro Pro version  I have a Word 2010 .docx document with hyperlinks in it that I want to convert to a PDF with the hyperlinks intact, but can't seem to do it.  It didn't work on the base installation, so I went into preferences & put a check in "Convert Links" only.  I restarted both Nitro & all Office docs.  When I drop the Word document it starts the conversion, but errors out quickly with a pop-up telling me the Word add-in is disabled or installed incorrectly.  When I click on OK, it says the PDF couldn't be converted.  It suggests reinstalling the Word add-in or to deselect "Convert Links".  I looked up how to do that, ran the support tools as an admin & reinstalled the add-ins.  I restarted everything & still get the same error.  If I deselect links, the PDF conversion completes just fine, but leaves me with the original problem - No Hyperlinks!  How do I fix this?

Link to comment
Share on other sites

Jim MacLachlan

I can't seem to find any other options for support for this issue besides the knowledge base which I've gone through extensively or these community forums.  It's been several days now with no answer.  Doesn't Nitro support their software anymore?  They used to be great & I purchased many copies for our company.  I retired, so just purchased it for myself.   I'd hate to find the company doesn't stand behind their product.

Link to comment
Share on other sites

Jim MacLachlan

How I convert the Word document seems to make a difference.  I get the error above when I drag & drop a Word document into Nitro.  I also get the error if I open Nitro & choose convert & choose the file.  If I leave Nitro closed, click on the Nitro tab in Word & choose create a PDF, it works without a problem - even creates the hyperlinks & bookmarks correctly.  I guess that will do, but I am terribly disappointed by the lack of support.  I'm no longer in charge of purchasing this software, but you lost that account.  Timely support is too important & obviously it is no longer a priority for your company.

Link to comment
Share on other sites

  • Official Nitronaut
Reymund Oyong

Greetings @Jim MacLachlan,

Thank you for reaching out through our Community Forums!
We apologize for the inconvenience this issue has caused and for the delay in reaching back to you in this forum post. 

To check if the convert functions are working, I tried all the conversion methods of Word to PDF in Nitro PDF Pro and they were all working on version 14. 

When converting a Word file to PDF using the add-in and you would like to retain the hyperlinks, the 'Convert Links' checkbox must be checked. 
But when converting using the following workflow (see below), the 'Convert links' found in the Preferences > Create PDF from > Microsoft Word must be checked. 

• Right-clicking the Word file and select 'Convert to PDF with Nitro PDF Pro'
• Dragging and dropping the Word file in Nitro PDF Pro
• Home tab > PDF > From File > Add Files > Create

From what I understand, any of the above conversions (except the Add-in) are not working and they generate an error message. 
Could you please provide the exact error message including a screenshot? And, is this error only occurring when converting a Word PDF file to PDF? 

Lastly, does the conversion issue happens to any Word file that you convert to PDF?
If the behavior/error is specific to some Word files, you may share a copy of the Word file so we can test it on our end. 

Kind regards,

Link to comment
Share on other sites

Jim MacLachlan

I am NOT converting a Word PDF file as you wrote toward the bottom of your message.  There is no such thing that I'm aware of.  I am converting a .docx file.  I've also tried just .doc files.  All have the same problem.

When I right click on a Word doc, drag & drop, or open it while in Nitro with  'Convert links' found in the Preferences > Create PDF from > Microsoft Word checked, I get the following error:  "Your Nitro PDF Pro Word add-in is disabled or installed incorrectly.  To continue, please enable/re-install Word add-in & try again.  Alternatively, you can deselect 'Convert Links' & 'Convert headings to bookmarks' to continue."  The only option is to click "OK".  (I can't seem to get a picture on here.  I posted the link to my Google pics, but your system won't accept the link.)  EVERY Word document I try to convert in that manner, whether it has a hyperlink in it or not, fails with the same error.   The only solution has been to uncheck 'Convert Links' or it is totally useless with Word. 

I can convert a Word doc if I use the Nitro tab in Word & check "Convert Links" whether or not the 'Convert Links' is checked in Nitro.  It works with bookmarks, too.  I've tried it on several files both with & without hyperlinks & never had a problem.  (It's not Home-PDF-Create, it has an entirely separate tab.) 

I have checked the Word Add-ins for any third party ones that might interfere.  The only third party add-in is Nitro's.  The rest are standard for Word 2010 & are from Microsoft. 

I have uninstalled & reinstalled the add-ins using the tools running as Admin several times. 

I've rebooted & reinstalled Nitro, too.  I have not uninstalled it since I'm worried about getting it running again.  The licensing requirements are brutal & often have problems.  (I've been supporting Nitro at my company for about a decade now.)  Given the support options available to a non-commercial user & the response time, I'm not willing to take a chance.

I hadn't tried converting links with any other Office program, but since you asked I tried it with Excel.  That works just fine in or out of Nitro.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.