Jump to content

Click inside multipage document, jumps to the first page! Tech Support lacking

Jonathan Selig

Recommended Posts

Jonathan Selig

First I'd like to say that I've been using PDF Pen Pro since it first came out. Someone probably remembers when but, it was MANY years ago. Until Nitro took over I was always able to reach out directly to Tech Support and either get answers or alert them to 'bugs'. The responsiveness was so good that I've stayed with the product all this time and recommended it to others. 

I'm using Mac Studio 2023, OS 14.1.2 Sonoma with 64Gb RAM along with PDF PenPro 13.3.1.

Since upgrading to this computer and OS, I've encountered this odd and thoroughly frustrating problem.

The problem is consistent in multi-page documents whether I've authored or assembled them or if they are catalogs from other sources. 

Pick a page from the Thumbnail, click on the page selected and I'm automatically taken back to page 1. The only way I can work on a page within a document is to scroll through the actual document until I reach the page I need to edit. 

I've tried removing and deleting PDF PenPro and then reinstalling it. I've tried restarting the computer and doing the same. So far, I'm suffering with the problem and don't seem to be able to reach anyone who has an answer. Please help.

Scrolling forever,




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.