Jump to content

Can't open any PDF files with nitro pro 14

moran kamer

Recommended Posts

moran kamer

Hi, I've recently encountered an issue where I cant open any PDF files through pdf nitro 14 
it keeps giving me an error message saying : "XXX.pdf could not be opened because its open parameters are invalid or incomplete. If this is a cloud document, make sure you are properly logged in to the cloud provider." 

I've tried to open the file from inside the program but to no success 
I've tried to reinstall the program and also restart the computer multiple times but to no success 
I've tried to open a PDF file from both local and network locations but to no success 
other PDF programs such as "Adobe" and "Foxit" works fine with the same files 
also PDF nitro 13 works fine as well 
my version is : 
I'll appreciate your quick response  
Thank you

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.