Jump to content
Bob Richards

Version 11 Very Slow to Open

Recommended Posts

Bob Richards

I bought V. 11 for a new Lenovo WIN 10 X86. Nitro Pro is very slow to open and when I try to print it kills the program.  HELP!

  • I agree 1

Share this post


Link to post
Share on other sites
AllainU

Hello @Bob Richards,

Thank you for reaching out to us through our Community Forums!

Microsoft has identified an issue with their fall update of which has caused some programs like Nitro to run slower than normal.

We have decided to release a patch to our 11.0.7 build in January that will contain the fix related to Windows 10 Fall Creator Update issues.

We will let everyone know when is the exact date of this release as soon as we have this information. 

We also highly recommend regularly checking our download page to get the next build: https://www.gonitro.com/product/downloads

Again, thanks for being our loyal customers and thank you for being patient while we provide the fix. 

Cheers and Happy New Year!!!

Share this post


Link to post
Share on other sites
David O'Connell

I have a recently purchased license version 11.0.5.271 which has gotten very, very slow to open PDF files, often longer than a minute.  I also have checked my updates button, which states that my version is the most current, although the release notes at this page https://www.gonitro.com/product/documentation/release-notes state newer updates are available.  Should I wait for this update to load automatically, as I assume it is supposed to, or should I actively download and install this update?

Second, will this update address the slow loads I have encountered?

D.

Share this post


Link to post
Share on other sites
Alex E.

Hi @David O'Connell

You will need to download the update via the downloads page that Allain mentioned above.

The update will target some specific issues that were introduced with recent Windows updates, which match the description of the issues you are experiencing.
However, it's possible the problem on your computer is similar, though different. If that is the case, further investigation will be required.

I recommend keeping an eye out for the update on our downloads page.
If you continue to experience problems after the update, please don't hesitate to contact us again.

Share this post


Link to post
Share on other sites
James Middleton

I have Pro 10

I have a superfast  desktop i7Core with 32GB Ram and SSD drives Win10 64 bit

Pro 10 takes 12-13 seconds to load Pro 10 Quicksign feature also slow to load

No other programs from other vendors have this problem

 

Share this post


Link to post
Share on other sites
David O'Connell
1 hour ago, Alex E. said:

Hi @David O'Connell

You will need to download the update via the downloads page that Allain mentioned above.

The update will target some specific issues that were introduced with recent Windows updates, which match the description of the issues you are experiencing.
However, it's possible the problem on your computer is similar, though different. If that is the case, further investigation will be required.

I recommend keeping an eye out for the update on our downloads page.
If you continue to experience problems after the update, please don't hesitate to contact us again.

Dear Alex:

I attempted to do as you suggested, to download the 11.0.7 upgrade to address the degraded performance in the version I bought on Cleverbridge's reference number 120840453  in October 2017.  When I entered my serial number, which I had copied from my sales invoice email, and confirmed from the About dropdown menu in the program, the server suggested an error, and that I should return here to seek assistance.  

What do you suggest?

D.

Share this post


Link to post
Share on other sites
Alex E.

Hi @David O'Connell, Please be aware that the update Allain and I have referred to has not yet been released.

On the downloads page, you will see that the current version was released in November.
Please keep an eye on that page over the next couple of weeks for the upcoming update.

With regards to the error you mentioned, you will need to provide a screenshot (taking care to avoid showing your serial).
I had a look at the serial associated with that purchase, it shows it was last activated on two computers in September.

Share this post


Link to post
Share on other sites
David O'Connell

Dear Alex,

I stand corrected, my purchase was in late September, if that makes a difference.

Attempts to use Windows CTRL-V conventions to paste screen shots into this thread failed. Your assistance will be appreciated. 

D.

 

 

Share this post


Link to post
Share on other sites
Steve1

Hi Alex

Do you have an ETA on the Win10 fix - Nitro 11 since the Win10 update has become almost unusable (same for 10 BTW), as the program now takes over 2 min to load, then crashes when looking to print. I have had to revert to Adobe Reader a few times for reading PDF docs. I have a Lenovo Yoga with i5 processor.

The sooner the better please. I use Nitro daily as a part of my consulting practice and it is an invaluable tool for myself and other Nitro PDF users!

Thanks Alex! Steve

Share this post


Link to post
Share on other sites
Alex E.

Hi @Steve1, The release date was pushed back slightly due to an issue found in the testing phase.
It is currently set for the end of January (approximately a week and a half away).

Hi @David O'Connell, the purchase date makes no difference. You should be able to drag and drop an image in to attach it.

Please let me know how you go.

Share this post


Link to post
Share on other sites
David O'Connell

I attempted to send the redacted error message, a *.png file a number of different ways. All failed. 

 

Share this post


Link to post
Share on other sites
Evelyn

This might sound like an odd thing to try, but it worked for me: uninstall Adobe Reader. I started having the same problem a couple of weeks ago after I first installed Adobe Reader on my Spectre. I've used it NitroPro on it for three years with no problem, but as soon as I did that install, NP slowed to a crawl while Adobe worked like a dream. Uninstalled Adobe Reader, restarted, and things have (almost) returned to normal with a 3-second lag.  

Share this post


Link to post
Share on other sites
Mario K.

@Bob Richards please check out my latest announcement (top of page) where I posted 11.0.7 patch installers. 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.