Jump to content
Jason Unger

Always shrink to page when printing

Recommended Posts

Jason Unger

Hello,

One of our clients has purchased Pro, and a vendor periodically sends them PDFs that end up printing oversized (IE, when printed, the content extends beyond the printable area of the page). If we select "Shrink to page" when in the printing dialog, things print fine. Printing from Chrome and Adobe Reader result in a proper print as well.

Is there a way to always have "Shrink to page" selected, or other setting to properly print these seemingly oversized PDFs? This only occurs with PDFs from a specific vendor.

Thanks

Share this post


Link to post
Share on other sites
Steven Zakulec

Yes- you should be able to set this, but you need to set a registry key in order to do so.

All the usual caveats apply here- you should have backups, only edit what you need to, and if you're going to file a support ticket, let them know- this particular change is unlikely to have an impact, but you never know.

With all of that out of the way, here's what to do:

You want to create and/or edit the kPagePrinterScaleSelector key in Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences\kPreferences.

If the key does not exist, you want to create a String type key with that exact name (case and all).

There are 3 values that you can use: 0, 1, and 2.

Each corresponds to the Scale settings in the Print Dialogue:

0 is no scaling

1 is Expand to fit

2 is Shrink to fit

You'll want to have Nitro closed when you do this, and when you re-open it your change should take effect.

Good luck!

Share this post


Link to post
Share on other sites
mattmyers

I am having the same issue.  When I put the registry entry in and open nitro it deletes the entry after you go to print.  Any other suggestions?  Is this a bug?

Share this post


Link to post
Share on other sites
Jason Unger

Found that putting in the value "/i 2" wouldn't delete the value, but it still doesn't check that checkbox as described.

Share this post


Link to post
Share on other sites
Jason Unger

The above value was a guesstimate, based on the other variables under that registry key.

Share this post


Link to post
Share on other sites
Steven Zakulec

Sorry about that- as @Jason Unger mentioned, there is a format to the key.  For those keys, I believe /i 0 , /i 1 or /i 2 are the values.

There's other keys you can try, but that should be the primary one.

In that same list from above, you'll see kPrefPrintScalingShrink listed.  For this key, you should use /b 1 for on, and /b 0 for off.

The third option you can try is creating a key called PrintSettings in Computer\HKEY_CURRENT_USER\Software\Nitro\Pro\11.0\Settings\Preferences.

Inside, you'll create a string called kPagePrinterScaleSelector.  You'll use the same /i 0, /i 1, /i 2 as above for the value.

None of this is officially documented, and which key works may be totally dependent on the version of Nitro you have installed- if one of them works for you, I'd be thrilled to know which one and what version you are on.

Share this post


Link to post
Share on other sites
Steven Zakulec

So, the post here:

has an important note: NOTE: You are required to use the Ctrl + P shortcut rather than File > Print to utilise this.

I'm not sure if that's going to work for you, but it's worth a try.

 

Share this post


Link to post
Share on other sites
Oregunfarmboy

Sorry first time user.  I have Nitro Pro 11 and "type text" is not working?  Squiggly red line shows up where characters should be, but not text.  i can add signature and do other functions like highlight text, but can't make any text show up on my pdf?  Help.  thx

 

Share this post


Link to post
Share on other sites
Jason Unger

If this is the case, this implementation would seem to be shoddily done. One would think that code reuse would have it that the same variables would be used by all manners of achieving a print job. Additionally, a support person said there they were looking into a fix for this. Here we are, almost a year later, and still no resolve? The above post is a bandaid, not a solution.

Share this post


Link to post
Share on other sites
Steven Zakulec

I think the fix is that Nitro remembers your print settings, and doesn't reset them each time to the defaults.  Otherwise if there's something else you'd like to see happen, post it in the Product Improvement forum.

 

Share this post


Link to post
Share on other sites
YAncey

I just downloaded the latest version of Nitro and I am having a printing issue. I can not keep the setting on (scale to fit) under the effects tab in the print properties. Is there a way to keep that as a default every time that I print?

 

Thanks

Share this post


Link to post
Share on other sites
Steven Zakulec

Did you try any of the registry keys from above?  On the latest version, the kPagePrinterScaleSelector key one should work- I've used it successfully on 11.0.7.4.11 & 425.

If you're looking for a non-registry key option, that doesn't exist yet as far as I know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use.