Jump to content

NItro Pro Decryption


wisty
 Share

Recommended Posts

 I currently have Nitro Pro 9, and tried ( back in 2017) a trial copy of Nitro Pro 11.

I routinely use PDFCreator as my PDF printer. However PDF's created with PDFCreator (http://www.pdfforge.org/pdfcreator) and encrypted with 128 bit AES encryption, either partially or fully, cannot be opened with NitroPro version 9 or 11 using the correct password. Nitro simply keeps asking for the password. I reported this to Nitro in April last year as Nitro Support Case - 00102971 - Opening Copy Secured PDF's and was told that they "... were able to replicate the issue using the file that you sent. This looks like a compatibility issue between PDFCreator and Nitro Pro. I apologize, but we cannot offer any workaround at the moment."
 
The PDF's created and encrypted  by PDFCreator CAN be opened by ALL the
other PDF readers I have tried
        MIcrosoft Edge Browser
        Microsoft Reader
        PDFAnnotator
        SumatraPDF
        Foxit Phantom
        Microsoft Word
        DrawboardPDF
 
PDF's created and encrypted with 128bit AES by Nitro's printer can be opened in Nitro 9 & 11 and with all the other readers. That suggested a problem with the implementation of the decryption library in Nitro.
 
Does anyone know if this issue has been identified and resolved for V12? I tried to query this with Nitro directly, but got the standard automated response that the query was closed.
 
I would be happy to provide the sample document, but I can't seem to work out how to attach it to the post. I can see - "Insert existing Attachment" as an option, but when I try that it says "You do not have any existing attachments." and I  can see no obvious way to create one. I tried to upload the document to the Nitro cloud, but it refused to let me  "because the document is encrypted", which sort of defeats the object!
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.