Jump to content

Nitro Pro 13 won't open


Recommended Posts


I bought Nitro Pro 13 a few days ago. Everything was working fine yesterday.

This morning I wanted to open a pdf document and it won't load. I tried restarting my computer and reinstalling the program. Still unsuccessful.

Everytime when I tried to launch Nitro Pro, the startup logo pop up will appear and Nitro icon will appear on my taskbar, but the window won't. Task manager shows that Nitro Pro is running.

If I tried opening a pdf document, the same thing happens. Icon will appear on my taskbar, task manager will show that it is running, but the actual window won't appear. HELP! I need to work.

Link to comment
Share on other sites

  • 3 months later...
Christopher Lloyd

We also have a user with this same problem. They will attempt to launch the program, but it will never full open. Reboots and program reinstalls do not fix the issue. Hoping a Nitro Support Rep will see this and be able to help out.

Link to comment
Share on other sites

Christopher Lloyd

In case it will help anyone else, I heard back from Nitro support and the solution they provided worked for my user.

They mentioned how it is a common scenario when multiple monitors are being used. When Nitro Pro is opened on a monitor that is later disconnected, it won't default to a current "active" display which causes Nitro Pro to display on the missing monitor. Solution was to:
1. Focus on Nitro Pro by clicking on it on the Taskbar.
2. Press the Windows key + Left/Right arrow until Nitro Pro appears.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.